AC.log Pro - Using the program [Back to Start Page]

Using the program

Overview

The program's graphical user interface (GUI) is quite simple. There are four menus, "File", "Tools", "Options", and "Help", and the main screen with the three sections "Log File Set", "Report", and the report itself.

Please note context sensitive help is always available by pressing "F1". Or hover of a control to get some short information.

The "File" menu contains only one option, "Exit" which quits the program.

The "Tools" menu is not active yet. Release 1.1 will feature a multithreaded resolver which looks up 10 or more IP addresses in parallel (currently, use "Options - Numeric Address Resolution").

The "Options" menu lets you select the "Look and Feel" (the appearance) of the GUI, and the mode of numeric address resolution (for more information, see Countries by requests).

AC.log Pro has four modes for reverse name lookup (translating numerical IP addresses into the name form):

Please note that you have to be online for reverse name lookup, and that in release 1.0 the function can be very slow because only one lookup is made at a time.

The next release will feature a multithreaded lookup that performs a number of searches at the same time (see "Tools - Resolve addresses").

The "Help" menu offers access to the context sensitive help and to the "About" text.

Log File Set

If log file sets are already defined, they are shown in the selection box next to the "Manage" button. When you select a log file set, analysis starts automatically. To create, modify, and delete log file sets click on the "Manage" button, and a new dialog will appear.

Manage log file sets

First, either select the log file set you want to work on, or create a new set by clicking on "Create".

Now you can add or remove log files with "Add" and "Remove" (selecting more than one file at a time is possible), create a copy with "Save as", revert to the saved state with "Revert", or delete the set with "Remove".

When you're done, exit with "Analyse" to start analysis right away, or with "Ok" to just leave the dialog.

Report

The report selection has four selection boxes, "View", "Group", "Report", and "Style". Hover with the mouse over each field to get some more information.

"View" selects your standpoint. Are you responsible for the content, or do you run the infrastructure? Select the view which fits your needs best.

"Group" selects the report group. Reports have been grouped by "theme" to avoid having to browse through a single long list for reports which belong together.

"Report" selects an individual report and shows it in the report section of the screen. Depending on the report, one or more visualization styles might be avilable.

Report visualization

The following report styles are available:


© 1999-2002 Christian Treber, aclogpro@acproductions.de